Issues on our Cloud

Incident Report for Metabase Cloud

Resolved

Service has been restored, we will provide more details about the issue as soon as possible. In case you have further questions, please reach out to our support email.
Posted Oct 11, 2022 - 17:53 UTC

Update

We are continuing to investigate this issue.
Posted Oct 11, 2022 - 17:43 UTC

Investigating

We're currently investigating an issue that is causing downtime on our Cloud
Posted Oct 11, 2022 - 17:43 UTC
This incident affected: Metabase Cloud Platform.