Unable to create new Metabase cloud instances

Incident Report for Metabase Cloud

Resolved

This incident has been resolved.
Posted Jul 29, 2023 - 10:21 UTC

Investigating

Metabase customers trying to create a new cloud trial or cloud instance are unable to do so.
Posted Jul 28, 2023 - 13:10 UTC
This incident affected: Metabase Store.