Metabase Store is unavailable due to maintenance

Incident Report for Metabase Cloud

Resolved

We are continuing to investigate this issue.
Posted Aug 19, 2023 - 13:52 UTC

Update

We are continuing to investigate this issue.
Posted Aug 19, 2023 - 13:50 UTC

Investigating

We are preforming routine maintenance on the Metabase Store infrastructure. We expect it to be fully operational within the hour.
Posted Aug 19, 2023 - 13:09 UTC
This incident affected: Metabase Store.