Unable to send outbound emails

Incident Report for Metabase Cloud

Resolved

This incident has been resolved.
Posted Jul 29, 2023 - 18:48 UTC

Investigating

Metabase Cloud customers are unable to send outbound emails temporarily
Posted Jul 29, 2023 - 15:11 UTC
This incident affected: Metabase Cloud Platform.